Reinhard Weiß - Reparaturanleitung
WiFi Repeater Maginon WLR-755 AC, Reparaturanleitung

WLR-755 ACDen WLR-755 AC WiFi-Repeater gab es bei Aldi 2016 (Marke Aldi) und 2017/2018 (Marke Maginon) für unter 20 €, und als Restposten sogar für unter 10 €. Garantie ist 3 Jahre. Es handelt sich um ein Steckdosengerät, das als Repeater, AccessPoint und Mini-Router konfigurierbar ist. Im Routermodus stehen 2 RJ45-Buchsen zur Verfügung (100 MBit/s). Anders als viele Billiggeräte hat es die Standards 802.11 ac/a/b/g/n, d.h. b/g/n bei 2,4 GHz und ac/a/n bei 5,0 GHz, mit einer werblichen Übertragungsgeschwindigkeit von bis zu 733 Mbit/s. Als Verschlüsselungen wird WEP/WPA/WPA2PSK unterstützt. Auch WPS steht zur Verfügung. Das letzte Update der Firmware auf den Seiten von Maginon ist von 7/2019. Erstaunlicherweise gibt es bei eBay derzeit (4/2020) Angebote gewerblicher Händler, die über 50 € für ein neues Gerät verlangen. Auch auf der WebSite von Maginon kostet das Gerät stolze 40 €. Ansonsten wird das Gerät gebraucht bei eBay meist deutlich unter 20 € (inkl. Vk) angeboten.

Hürden bei der Inbetriebnahme

Es gibt in einschlägigen Foren Diskussionen, wo Anwender enttäuscht oder verzweifelt sind, weil das Gerät sich nicht immer so verhält, wie gewünscht. Vielfach geht es darum, dass nach der Konfiguration unter der IP 192.168.10.1 das Gerät zur Konfiguration nicht mehr im LAN erreichbar ist. Manch einer empfiehlt dann, die Konfiguration auf Werkseinstellungen zurück zu setzen und neu zu konfigurieren. Auf diese "Falle" war ich anfangs auch gestoßen und bei meiner Anfrage bei der Hotline hat man mir doch tatsächlich die gleiche Empfehlung gegeben. Eine andere Möglichkeit sehe man nicht. Dabei ist es ganz einfach. Man muss bei der Konfiguration nämlich daran denken, eine feste IP zu wählen aus dem DHCP-Bereich des Routers. Dann kann man die Konfiguration jederzeit wieder über diese Adresse aufrufen. Anderenfalls vergibt der Router über DHCP eine zunächst unbekannte IP, die man erst herausfinden muss. Entweder fragt man sie dazu im Router ab oder man verwendet ein Tool wie netscan, das alle vorhandenen MAC- und IP-Adressen im LAN auflistet.

Andere Schwierigkeiten scheint es teilweise bei den richtigen Einstellungen zur Repeaterfunktion zu geben. Für alle Betriebsarten gibt es aber Assistenten, die die Einstellungen erleichtern. Beim Reset auf Werkseinstellungen gibt es widersprüchliche Anweisungen, mal solle die Reset-Taste für nur 10 s (altes Handbuch), dann aber für 20 oder mind. 30 sec (Hotline und neues Handbuch) gedrückt gehalten werden. Manchmal hilft es auch, das Gerät über den Schalter aus- und wieder einzuschalten. Es ist hilfreich, wenn man für die erste Konfiguration das Gerät noch nicht ans vorhandene LAN anschließt, weil anderenfalls das noch offene WLAN eine Angriffsfläche für das Netzwerk bietet, und einem auch das DHCP des Netzwerks "dazwischen funkt". Stattdessen verbindet man einen unabhängigen PC entweder über das offene WLAN oder über ein LAN-Kabel mit dem Gerät. Erst danach steckt man auf das Netzwerk um und bekommt Verbindung zum Internet. Wenn alles funktioniert, sollte man die Einstellungen sichern (blaues Menüfeld Einstellungen Speichern/Laden). Die aktuelle Firmware gibt es bei Maginon.

Leider kommt es bei dem Gerät anscheinend manchmal auch zu merkwürdigem Verhalten, dass Daten verloren gehen. Etwa wenn es mehrere Tage nicht eingesteckt oder eingeschaltet war, dass dann die Konfiguration verstellt oder zerstört sei, wie einige Anwender berichten. Es stellt sich die Frage, ob zum Speichererhalt vielleicht die Netzspannung erforderlich ist. Zumal der kleine Netzschalter seitlich am Gerät eben nicht das Netz ausschaltet, sondern nur den Stromversorgungsausgang unterbricht. Zumindest die Hotline behauptet aber, dass es beim Abstecken zu keinem Datenverlust kommen dürfte. Aber genau das ist mir auch passiert, es waren danach die Passworte, die IP und die SSID des Netzwerks verstellt (SSID stand auf "WiFi-Extender"). Vielleicht lag es auch daran, dass ich vor dem Herausziehen aus der Steckdose den Ausschalter am Gerät nicht benutzt hatte, und das langsame Absinken bzw. "Prellen" der internen Versorgungsspannung stört. Die Konfiguration konnte ich aber leicht rekonstruieren, indem ich die Datensicherung zurück geladen habe.

Bei einem weiteren Test mit 11 Tagen ohne Spannung waren die Daten allerdings nicht verändert (da hatte ich aber den Ausschalter benutzt). Andererseits trat bei mir einmal ein Datenfehler bereits beim Umstecken des LAN-Kabels im Betrieb auf, wobei allerdings nur die IP verstellt war. Nach Herausfinden der mittels DHCP vergebenen Adresse im Router konnte ich das wieder korrigieren, sonst war nichts verstellt.

Die Tatsache, dass es keinen "echten" Ausschalter für die Netzspannung gibt, was ja auch sonst häufig aus Kostengründen gemacht wird, bedeutet ja, dass das Gerät im angesteckten Zustand immer unter Spannung steht, selbst wenn es ausgeschaltet ist. Da könnte man befürchten, dass es irgendwann auch mal an Überspannung aus dem Netz stirbt, ohne dass das gleich auffällt. Eine Sicherung hat man sich auch gespart und sie durch einen 10 Ohm-Widerstand in der Netzleitung ersetzt. Daher besser ausstecken, wenn man das Gerät längere Zeit nicht benutzt. Die im Leerlauf verbrauchte Leistung ist mit 0,1 W aber nicht so erheblich.

Für Datenverluste nach Spannungsabschaltung wurde im Forum computerhilfen.de von bmwmini der Tipp gegeben, dass in seinem Fall der "Kondensator 680 µF" defekt gewesen sei und den man tauschen solle. Leser Jogy888 bestätigte diese Abhilfe. Was das mit den Daten zu tun haben könnte, wurde nicht diskutiert bzw. beantwortet. Stattdessen habe ich kürzlich bei meinem Gerät eine kleine "Explosion" erlebt mit Rauchwolken, als ich es getestet habe und es noch auf dem Schreibtisch stand. Ich konnte den Strom schnell abschalten, bevor der Rauchmelder ansprach. Das war eine Gelegenheit, mir das Innere des Geräts anzusehen.

Öffnen des Gehäuses

Um das Gerät zu öffnen, muss man zunächst die kleinen Stopfen auf der Unterseite (beim Netzstecker) mit einer Nadel entfernen und die beiden Kreuzschlitz-Schrauben darunter heraus drehen.

WLR-755 Dann hebelt man durch die Schraublöcher mit einem nagelförmigen Werkzeug den Deckel etwas auf, und fährt dann mit einem feinen Schraubendreher in den sich öffnenden Spalt, um den Deckel auszuklinken. Hier ist Vorsicht angebracht, um die kleinen Rastbügel im Deckel nicht abzureißen. Im linken Bild ist zu sehen, wo sie sich befinden. Da sie recht unflexibel sind, muss man eher die jeweilige Seitenwand des Unterteils nach außen biegen, als die Bügel nach innen zu drücken oder den Deckel mit Kraft heraus zu reißen. Danach lässt sich der Deckel einfach ablösen.

Die Innereien sind in der unteren Bildreihe zu sehen. Die obere Leiterplatte mit der Digitaltechnik und den RJ-Buchsen ist mit 2 Schrauben befestigt. Zum Entfernen muss man auch den kleinen weißen Stromversorgungsstecker vorsichtig herausziehen (hebeln). Die unter Platine ist die Stromversorgung in Form eines Netzspannungs-Schaltreglers, der mit dem IC FT838NB1 auf der Unterseite arbeitet (mittlere beiden Bilder). Das gelbe eckige Teil ist der potentialtrennende Übertrager.
WLR-755WLR-755 WLR-755WLR-755 AC

Den besagten Elko 680 µF fand ich schnell, weil er sichtlich aufgequollen war (roter Pfeil, Detailbild rechts). Er sitzt an der Ecke der Stromversorgungsplatine auf der Oberseite. Die Sicherungskappe sieht zwar unzerstört aus, aber ein Brandfleck in der Isolierfolie darüber zeigte, dass da zumindest eine hohe Temperatur geherrst haben musste. Auch in der Gehäuseschale waren Schmauchspuren.

Die Reparatur

Um den Elko auszulöten, muss man die Isolierpaste auf seinen Lötstellen auf der Unterseite der Platine zuvor wegkratzen.

Es handelt sich um einen Elko 680 µF/10 V mit den Abmessungen D 8 mm, H 11 mm, RM 3,5 mm. Dieser Kondensator liegt am Ausgang des Schaltregler-Moduls und wird mit Sicherheit von großen Spitzenströmen gestresst. Dies hat er nach nur wenigen Betriebsstunden nicht überlebt. Seine Kapazität war praktisch nicht mehr vorhanden (je nach Messfrequenz 26 µF @100 Hz bis 0,4 µF @100 kHz; gemessen mit PeakTech 2170), sein ESR lag dafür beachtlich hoch (93-132 Ohm @100 Hz bis 21-33 Ohm @100 kHz; gemessen mit PeakTech 2170 und ESR70). Den habe ich dann ersetzt durch einen Standard-Typ, der im gleichen Gehäuse aber angeblich für 16 V ausgelegt ist. Vielleicht gibt das Reserven (die Betriebsspannung ist nur 5 V). Es sollte eigentlich ein "LowESR" sein, d.h. mit geringem ESR (dieser hat 0,2 Ohm), aber die beengten Einbauverhältnisse lassen keine größere Bauform zu. Ein sehr gut geeigneter Typ passender Größe (8 x 11,5 mm) und mit geringem ESR ist z.B. der Panasonic EEUFR1A681 (10 V), den es bei Völkner/Digitalo (W18476) bzw. Conrad (446708) und Reichelt (FR-A 680U 10) gibt (max. Ripple Current eff. 950 mA, Impedance 56 mOhm @100 kHz).

WLR-755Um noch etwas Licht in die Angelegenheit zu bringen, habe ich von der Netzteilplatine im Gerät den Stromlauf aufgenommen (Bild links). Die Schaltung ist ein primär getakteter Schaltregler mit dem FT838NB1 und beinhaltet nichts Besonderes, der besagte Elko ist der C7 rechts außen. Er liegt als Glättungskondensator am Ausgang der Schaltung, die 5 V liefert. Wie schon erwähnt, gibt es keinen Netzschalter, das Netzteil steht also immer voll an Netzspannung, wenn das Gerät in die Steckdose gesteckt ist. Der Ausschalter sitzt auf der Digitalplatine und unterbricht nur die Stromzufuhr dorthin. Statt einer Sicherung soll wohl lediglich der Widerstand R1 links oben im Zweifelsfall "kontrolliert abbrennen", wenn es einen Kurzschluss geben sollte. Ob das wohl gut geht?

Wenn ich sehe, wie an mehreren Stellen silikonartige Isolierpaste zur Fixierung und zusätzlichen Isolierung der Bauteile und Leitungen hingeschmiert wurde, frage ich mich, ob hier nicht eine schludrige Fernost-Fertigung kaschiert werden sollte. Immerhin sind die Kriechwege auf der Leiterplatte zwischen Netzspannung und Ausgang vorbildlich gestaltet (großer Abstand und mit Frässchlitz). Die Übertrager im Netzteil und auch bei den LAN-Schnittstellen haben allerdings keine sichtbaren Prüfzeichen (was für die Berührungssicherheit wichtig ist). Zur "Schludrigkeit" gehört auch, dass der Beschriftungsdruck an einigen Stellen falsch orientiert ist (D6, D7), dass die Benummerung fehlerhaft ist (R11 doppelt, R10 fehlt), dass 1 Widerstand nicht (mehr) angeschlossen ist und fehlt (R7), dass die abgehenden Anschlussdrähte des Ausgangs keine eigenen Lötaugen abbekommen haben und nur die Lötstellen von C7 mitbenutzen...


Beim Zusammenbau muss man darauf achten, dass der kleine Schiebeschalter richtig in dem Schiebeknopf, der in der Gehäuseschale verbleibt, eingefädelt wird.

Nach Austausch des Elkos funktionierte mein Gerät wieder. Und die Daten waren auch noch alle da und unverändert. Das ist dann auch der Beweis, dass der Elko nichts mit der Datenerhaltung (Pufferung) zu tun haben kann, denn während der Reparaturzeit war die Digitalplatine tagelang völlig ohne Strom. Denkbar wäre nur eine Fehlfunktion, wenn durch einen defekten Elko die Betriebsspannung nicht mehr ausreichend geglättet wird (das passiert beim Anstieg des ESR durch Erwärmung und Alterung).

Falls einmal eine Reparatur des Netzteils nicht erfolgreich sein sollte, könnte man das Digitalmodul auch ausbauen und separat betreiben mit einer passenden Stromversorgung (z.B. Steckernetzteil 5 V/1 A) über den weißen Stecker vom Typ JST, Serie PH, RM2,0. Polarität beachten. Beim Inbetriebnehmen aber nicht vergessen, dass noch ein kleiner Ausschalter in der Nähe dieser Stiftleiste sitzt.

Hinweise:

Quellen & Links:

(erstellt 01.05.2020, erweitert 17.05.2020)

[ Übersicht | SiteMap | Verkäufe Akt. | Verkäufe Hist. | EURACOM | GPS Navigation | M4650CR | M9803R | Back-UPS | Oki C5400 | GS9000 | WebLog | Bauprojekte | Impressum & Kontakt ]

nach oben Menü Home

© Reinhard Weiß 2020 - letzte Änderung: 17.05.2020 21:01 / 4